USDC-CAD Trading is Offline

Incident Report for Cybrid

Update

We are continuing to investigate this issue.
Posted Feb 04, 2026 - 11:11 EST

Investigating

We are currently working with our liquidity partner to resolve the issue and are awaiting their resolution.
Posted Feb 04, 2026 - 11:11 EST
This incident affects: Production (Bank API).