Temporary delay in USDC_NPL trades

Incident Report for Cybrid

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 09:49 EST

Investigating

The Circle is experiencing an issue on the Polygon blockchain that is causing delays in some of the USDC_NPL trades settlement on the Cybrid platform:
https://status.circle.com/incidents/5r4cm8n4tp2x
We are monitoring the situation and will provide updates.
Posted Feb 17, 2026 - 13:38 EST
This incident affected: Third Party Providers (Circle).