API and Partner Portal Issue due to Persona outage

Incident Report for Cybrid

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 18:49 EDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 12, 2025 - 14:55 EDT

Identified

Major Google Cloud outage affecting our core 3rd-party services.
Posted Jun 12, 2025 - 14:53 EDT
This incident affected: Sandbox (Bank API, Partner Portal), Third Party Providers (Persona API, Persona Inquiries & Collections, Fireblocks), and Production (Bank API, Partner Portal).